Degraded UPS Mail Innovations Rating Performance
Incident Report for EasyPost
Resolved
The UPS Mail Innovations API errors and request timeouts have subsided and the service has recovered.
Posted Nov 27, 2023 - 09:10 PST
Investigating
The UPS Mail Innovations API is experiencing elevated rates of
errors and request timeouts for rating.
UPS has been notified and our engineers will continue to
monitor the performance of the API.
Posted Nov 27, 2023 - 07:58 PST
This incident affected: Carrier Rating (UPS Mail Innovations).