Service Outage
Incident Report for EasyPost
Resolved
All systems are fully operational.
Posted Apr 16, 2019 - 10:03 PDT
Identified
The API is currently down due to a bad deployment. Engineers are rolling back.
Posted Apr 16, 2019 - 09:56 PDT
This incident affected: EasyPost Backend (API) and Website.