Partial Outage for Canada Post

Incident Report for EasyPost

Resolved

This incident has been resolved. Canada Post wallet accounts are operating normally.
Posted May 22, 2026 - 15:36 PDT

Monitoring

The fix appears to be holding. It is our fervent hope that this issue is now resolved. We will continue to monitor to ensure it doesn't recur.
Posted May 22, 2026 - 14:08 PDT

Identified

Working with Canada Post, we have identified the issue and are rolling out a fix. Wallet customers should start to see improvement soon. We are continuing with remediation on our side as we roll out the fix.
Posted May 22, 2026 - 13:37 PDT

Update

We are in contact with Canada Post and continuing to work to resolve this issue.
Posted May 22, 2026 - 09:35 PDT

Investigating

Customers using Canada Post wallet accounts may experience errors rating or buying labels. We are in contact with Canada Post and working to resolve this issue.
Posted May 21, 2026 - 18:18 PDT
This incident affected: Carriers (Canada Post).