Elevated error rates and response times for DHL Express
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 29, 2019 - 15:06 PDT
Monitoring
We are no longer seeing a high volume of errors from the DHL Express API. We will continue to monitor until the carrier has confirmed that the issue is resolved.
Posted 3 months ago. Apr 29, 2019 - 12:21 PDT
Identified
The carrier has acknowledged that their API is experiencing degraded performance. We have escalated the issue and are awaiting a response from the carrier.
Posted 3 months ago. Apr 29, 2019 - 09:45 PDT
Investigating
We are currently experiencing elevated error rates and response times for DHL Express. We are investigating the issue and have contacted the carrier.
Posted 3 months ago. Apr 29, 2019 - 08:07 PDT
This incident affected: API.