Elevated error rates and p95 for FedEx rating and label operations

Incident Report for EasyPost

Resolved

FedEx API has returned to normal error rates and response times.
Posted Oct 27, 2025 - 13:55 PDT

Update

FedEx API performance has largely recovered, however error rates are still elevated and we are still experiencing occasional periods of high p95 and rating timeouts.
Posted Oct 27, 2025 - 12:41 PDT

Monitoring

FedEx APIs have been returning elevated error rates and slower than normal responses, but look to be recovering. We will continue to monitor.
Posted Oct 27, 2025 - 09:44 PDT

Investigating

We are currently investigating this issue.
Posted Oct 27, 2025 - 09:18 PDT
This incident affected: Carriers (FedEx).