DHL eCommerce Elevated Error Rates
Incident Report for EasyPost
Resolved
Error rates have returned to normal.
Posted Feb 01, 2019 - 11:03 PST
Monitoring
We are experiencing elevated error rates communicating with DHL eCommerce. DHL has confirmed issues on their end.
Posted Feb 01, 2019 - 07:39 PST
This incident affected: EasyPost Backend (API).