Degraded API

Incident Report for EasyPost

Resolved

All systems have returned to normal and APIs are fully functional again.
Posted Aug 27, 2026 - 10:40 PDT

Identified

We encountered a brief degradation of the Core APIs during a deployment.

The change in question has been rolled back and API stability is improving.
Posted Aug 27, 2026 - 10:26 PDT
This incident affected: EasyPost Backend (Webhooks, API, Tracking, Address Verification).