USPS Label Broker® Outage
Incident Report for EasyPost
Resolved
This incident has been resolved, and we are seeing successful requests to the USPS Label Broker® service.
Posted Jan 19, 2024 - 23:05 PST
Identified
The issue has been identified and the provider has been notified.
Posted Jan 19, 2024 - 16:28 PST
Investigating
We are currently investigating this issue.
Posted Jan 19, 2024 - 16:24 PST